1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FS15 Mod Support 1950 Oliver HG High Crop v2.0

1950 Oliver HG High Crop Crawler 21.3 HP

  1. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    KaosKnite submitted a new download:

    1950 Oliver HG High Crop - 1950 Oliver HG High Crop Crawler 21.3 HP

    Read more about this download...
     
  2. mereman

    mereman Active Member PC-SG.uk Staff

    I have a funny problem with this mod on some maps like Old Times, which I use for a Classic farming series, when i try to buy the Oliver it locks the game up but on another map Westbridge Forest it works perfectly.
     
  3. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    I also play on Old Times map and have had no problem or errors when purchasing the Oliver (see attached screen shot). Check your error log for errors, if none, then check for mod conflicts. I use the default Old Times map with no alterations with no problem. Oliver Old times.jpg
     
  4. mereman

    mereman Active Member PC-SG.uk Staff

    I'll try again Thanks
     
  5. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    NP. If you have any errors in your log please post them and we will see if they can be fixed.
     
  6. mereman

    mereman Active Member PC-SG.uk Staff

    Looks like it's a conflict works perfectly (as I know all mods here will) with just the map and tractor. As I'm retired I have time to sort it before I start a new series using this kit.
     
  7. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    Good. I'm glad to hear that it's not a serious problem. I'm sure you will figure out what is causing it. Maybe if you find out what it is I can find a way to make it compatible. Let me know what you find out.
     
  8. mereman

    mereman Active Member PC-SG.uk Staff

    Great stuff. Much better then the classic pack. I will let you know what is the problem.
     
  9. mereman

    mereman Active Member PC-SG.uk Staff

    Looks like Courseplay (not going to be needed on this series). I'm using dev v401.0119. Took it out and Oliver loaded put a fresh copy back in removing all the saved courses and other bits first. It locked the game. Took it out and all was well.

    Should I kick Satis :D
     
    ShermyPermy likes this.
  10. Satis

    Satis Administrator Staff Member SOB Modding CoursePlay Developer

    Be careful about who you mess with :p
     
    Jim and mereman like this.
  11. Maleficent

    Maleficent New Member

    I'll second the issue, mod conflict with Courseplay. When you purchase there is a failure to "update" in the courseplay .lua script, so nothing happens.
     
  12. Maleficent

    Maleficent New Member

    Your Deere and Farmall don't have this issue, they work fine.
     
  13. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    I've never used course play and I don't know anything about it. I'll hand it off to my more knowledgeable colleague Satis to figure it out. Satis consider yourself kicked :p
     
    dj, mereman and Enzosnext like this.
  14. Satis

    Satis Administrator Staff Member SOB Modding CoursePlay Developer

    Hmm.
    I haven't been doing tests or modded for CP in quite a while, since I have been active wit other stuff. The best would be asking on github where CP is, even thou we developers there is not really active there. Thomas is the last one who have being doing updates on CP.

    I can take a look at some time, but I don't know if it will be before FS17
     
    mereman likes this.
  15. mereman

    mereman Active Member PC-SG.uk Staff

    No problem really I wasn't going to use CP for this series. For almost the first time I'm going to do most of the work;)
     
  16. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    Since Satis can only look for it @ the end of this year, I took a look at the mod and the Courseplaymod.

    I'am sorry KaosKnite, but it was a little error in the XML file of your tractor. I do not understand how a certain person of the testing team missed this error, but since we do not know who that is, he will come off clean.

    for all that cannot wait for an update, and do know a bit about modding, you can replace line 19 of the Olivier_HG.xml file for the following line:
    Code:
    <ackermannSteering rotSpeed="60" rotMax="35" rotCenterWheel1="0" rotCenterWheel2="1" rotCenterWheel3="2" rotCenterWheel4="3"  />

    the only changes are the indexes of the rotCenterWheel1-4


    easy fix, I think an update will follow soon, thanks everyone for reporting this error
    but please have a look at your log next time, it showed me a quick path to this solution
     
    Last edited: May 17, 2016
    mereman and Enzosnext like this.
  17. mereman

    mereman Active Member PC-SG.uk Staff

    Thanks dj that's twice you have helped me out.
    Well all the log told me was that CP wasn't happy, but I'm not a modder just a bodger:p
     
  18. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    it told you that line 1077 of the vehicles.lua inside the CP mod had a nil value (=no value). so someone with a tiny bit of lua scripting knowledge (me) can have a look at that line and see what can be missing in the tractor xml file. (this only works sometimes)

    I am trying to make a wiki page on the logfile, so you can learn what information you can find.

    When trying to help someone it is not always possible to recreate the same "error" situation
     
    mereman likes this.
  19. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding


    Cool. Thanks DJ. I have uploaded an updated v2.0 with the fixes mentioned here.
     
    Last edited: May 18, 2016
    dj likes this.
  20. KaosKnite

    KaosKnite Media Staff Staff Member Media Staff SOB Modding

    mereman likes this.

Share This Page