1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Converting mod from fs15 > fs17

Discussion in 'Ingaming' started by McGill2009, Dec 7, 2016.

  1. McGill2009

    McGill2009 New Member

    Any one here able to give me some guidance with fixing errors in my logs, am trying to convert the NI MODDING Kane trailers, I have them ingame but they are just a paper weight currently. I am only looking the trailer for private use, what would my best way of getting help?

    Niall
     
  2. Carl

    Carl Site Fiddler Staff Member Media Staff SOB Modding

    Feel free to post on here with what help you require.
    Please if you have the mod in game attach your log file as this will help us see what problems your having.
    to do this click the "Upload File" and navigate to Documents > My Games > Farming Simulator 17 > log.txt
     
    McGill2009 likes this.
  3. McGill2009

    McGill2009 New Member

    As I said it shows in game no problem, I cannot attach it to anything
     

    Attached Files:

    • log.txt
      File size:
      7.7 KB
      Views:
      7
  4. Carl

    Carl Site Fiddler Staff Member Media Staff SOB Modding

    Thanks for the log.

    When converting a mod you have to change most things to the new settings. Using the converter is good but most has to be done manually.
    Best thing I can say is to have a look at an in-game trailer and look at yours, then compare them and convert that way.

    First problem to solve is your wheels, make sure this is correctly scripted (copy from an in-game trailer & adjust to your needs)
    once this is fixed it should solve the xml being printed in the log like it is at the moment, you can then see what else is wrong, if any.
     
  5. david34

    david34 New Member

    can anyone help me with this i am new to this and dont know much about ge or lua scrips and other stuff and dont know much about the xmls Untitled.jpg
     
  6. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    Custom scripts will not be converted by the auto convert tool, you have to look for vehicles in FS17 with approx the same functionality, and copy those scripts and see how they implemented.

    change the moddesc XML, see how they are made on FS17 vehicles, a lot of the shop info has been moved to the vehicle.xml file

    I think you can just use lights from a default giants vehicle and forget about the beleuchtung script
     
    david34 likes this.
  7. david34

    david34 New Member

    oh ok ty
     
  8. Golden

    Golden New Member

    Hello, I trying to convert bale trailer and have a little problem.
    My trailer sliding a side when tractor stops, anyone know how to write wheels lines in xml to avoid it?
    I tried to copy lines from many trailers but it did not help.
     
  9. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    it would be helpfull if you would at least post the wheel lines you have in your current xml, you can attach the XML file to a post, and maybe also show the trailer ingame with F5 (collisions visible), so we can see if it is not sliding on a collisionbox
     
  10. Golden

    Golden New Member

    ok :)

    <wheelConfigurations>
    <wheelConfiguration name="$l10n_configuration_valueDefault" price="0" >
    <wheels autoRotateBackSpeed="2.0">
    <wheel restLoad="0.8" repr="1>0" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    <wheel restLoad="0.8" repr="1>1" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    <wheel restLoad="0.8" repr="3>0" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    <wheel restLoad="0.8" repr="3>3" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    <wheel restLoad="0.8" repr="3>2" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    <wheel restLoad="0.8" repr="3>1" radius="0.6" initialCompression="20" forcePointRatio="0.3" suspTravel="0.3" spring="180" damper="180" frictionScale="1.5" hasTireTracks="true" tireTrackAtlasIndex="4" mass="1" hasParticles="true"/>
    </wheels>
    </wheelConfiguration>
    </wheelConfigurations>

    <maximalAirConsumptionPerFullStop value="0.5" />
    <brakeForce>0.4</brakeForce>

    http://uploadfiles.eu/16zqzcy91ywm/PTS12.xml.html

    [​IMG]


    thank you for help
     
  11. Enzosnext

    Enzosnext Administrator Staff Member SOB Modding

    Please can you upload your log or vehicle xml to the message rather than copy and paste into a message as xml's are accepted when you use the upload a file tab ;)
     
  12. Golden

    Golden New Member

Share This Page