1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FS17 Mod Support Game Extension 0.4.0.0

Extend the base game.

  1. Xentro

    Xentro Member Honorable Member Wiki Editor

    Xentro submitted a new download:

    Game Extension - Extend the base game.

    Read more about this download...

    If the mod doesn't load and/or you are getting
    "Error: Unsupported modDesc version"
    Please make sure you have updated your game before using this mod.


    This thread is only for errors, problems or suggestions for this mod.
    If you wish to comment about this mod please use the reviews tab
     
  2. GrizzlyBearSims

    GrizzlyBearSims New Member PC-SG.uk Staff

    One small bug I've found. I have the HUD Hider by Clod installed (link removed) When I have the Game Extention mod enabled, but I don't have screenshot mode enabled...I'm unable to hide all the huds. If I disable Game Extension, then when I hit ALT 1, all my huds disappear as designed.

    Anyone else see this behavior?

    I find it a little easier to remove my HUDs for a screenshot using ALT 1 then bringing up Game Extension and enable/disable screenshot mode. But love all the other features of Game Extension

    Also, please correct the title bar which currently reads Client Setting's and Server Setting's. There should be no 's. It should just read Client Settings and Server Settings.
     
    Last edited by a moderator: Nov 18, 2016
  3. Satis

    Satis Administrator Staff Member SOB Modding CoursePlay Developer

    Please don't double post. Edit your old post if none have posted since you last post ;)
    Posts have been merged into one
     
  4. Xentro

    Xentro Member Honorable Member Wiki Editor

    Your issues are fixed in the next update.
     
  5. Enzosnext

    Enzosnext Administrator Staff Member SOB Modding

    Sorry but I hadn't noticed this in testing, but might be worth changing the key binding to something other than "I" as in game we use "I" to tip so might be worth changing.
     
  6. Knut A.

    Knut A. Member NI Modding Wiki Contributor

    I agree wit the I button. I bound mine to R ctrl+I
     
    Enzosnext likes this.
  7. Xentro

    Xentro Member Honorable Member Wiki Editor

    Fixed, included in next update.
    The setting screen button will now be deactivated if your in an tip trigger with an loaded trailer.
     
    mereman and Enzosnext like this.
  8. TLBranch

    TLBranch New Member

    Not sure if this is a Game Extension issue or not, but I have been able to recreate this exploit since installing it.

    Map = Goldcrest Edit by Stevie v1.0.0.4
    Timescale at 5x
    Plant growth set to normal
    Game extension fruit growth during missions set to on

    If a growth cycle happens while doing a mission, it tuns off the plant growth, and I can go back to all the fields that I did a mission for in the previous growth cycle and instantly complete them with full money paid and near 100% time bonus rewards and the field I am working jumps to the first growth cycle as soon as the mission is done.
     
  9. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    new suggestion: I like the stop and go braking which is a selectable option in the game menu. but since the friends on our dedicated server like to use shuttle control, they turn stop and go braking off in the server menu settings, which unfortunatly affects all players, then you make it possible to make this stop and go braking selectable per individual player on the dedicated server? or MP?
     
  10. Jac

    Jac New Member

    Great mode thanks, but noticed if I turn off the AI overtime feature it is not being remembered between sessions I have to manually set it off each time I load a game.
     
  11. Xentro

    Xentro Member Honorable Member Wiki Editor

    stopAndGo is an server setting that we cant make per client.
    Best option would be to fix/update shuttle control depending on how it is scripted.

    Fixed in 0.2.0.0 ;)
     
    Enzosnext and Dafydd like this.
  12. chaseydog

    chaseydog New Member

    I'm playing on Stevie's 1.0.0.4 and have also seen that plant growth is getting switched to off despite growth during missions being enable in the extension. I hadn't traced it down to happening when the growth cycle changes as you have, but keep my eye on it now and see if that's when it happens for me as well.

    OK, I set growth to fast (though I usually have it set on normal or slow) and saved the game. I checked growth and it was still on fast.

    I did a fert job on field 20. Growth remained on fast while I was running the mission and after the mission completed

    Next I launched another fert job on 20 which completed instantly (known 1.3 bug) and checked growth. It was back to off. I reset it to fast and saved the game.

    Did the 3rd fert job on 20, this time growth stayed on fast.


    Test 2
    I took a fert mission on field 31, this time with plant growth set to normal. I started the mission and rechecked growth, it was off and this time it was grayed out. I quit out of the game and reloaded the save.

    I checked my settings in the extension menu and growth during missions was still enabled. I checked my growth setting and it was back to normal. I ran the fert mission on field 31 and growth remained on normal throughout the mission ( I checked several times). I checked growth after completing the mission and it was still on normal.

    I launched fert jobs 2 & 3 and growth remained on normal both times.

    Test 3

    Sugar beat harvesting mission on field 8. Growth on normal at start of mission but changed to off during the mission. I checked my settings in the extension menu and growth during missions was still enabled.


    I've done a couple of more test and for me the issue seems completely random and not tied to a change in growth cycle. Most of the fields I've tested on were on the south side of the map where Stevie had done the most editing.

    Test 4

    I tried a mission on the default Giants Gold Crest with the same mods I'm using on Stevie's edit and I'm having the same issue. Crop growth will be enabled in the extension mod, I'll have it set to normal in the game menu, but it will disable at some point during the mission, but not at the start of the mission. I checked crop growth 3 times while running a mission, it was on normal the first two times I checked but on off the third time.

    Next I'll try disabling mods and see if that helps.

    Test 5

    I ran a half dozen missions on Stevie's GC with all mods except the extension mod disabled and the growth setting held on normal, so I'm guessing it may be a conflict with another mod. The only mods that I use that involve key presses while I'm doing a mission are Drive Control and GPS so I'll start there. The only other one I can think of would be the crop destruction mod. I'll try to test this weekend
     
    Last edited: Nov 24, 2016
  13. TLBranch

    TLBranch New Member

    Interesting I was running into that too, but thought the conflict may have been with fast forward mod as that is when I typically see the plant growth cycle get turned to off and not during mission work.

     
  14. Enzosnext

    Enzosnext Administrator Staff Member SOB Modding

    I can only suggest that anyone with errors, problems or issues it's always worth uploading a copy of your log via the upload a file tab, might save you a lot of work :)
     
  15. chaseydog

    chaseydog New Member

    Enzo, excellent suggestion. The log looks clean to me but I'll deffer to those with more knowledge.
     

    Attached Files:

    • log.txt
      File size:
      22.9 KB
      Views:
      8
  16. Xentro

    Xentro Member Honorable Member Wiki Editor

  17. Nestoche

    Nestoche New Member

    I downloaded version 2.0 and I don't see the Fruit Growth during Mission in the Game Extension options. Has this been taken out?
     
  18. Enzosnext

    Enzosnext Administrator Staff Member SOB Modding

    No fruit growth should still be switched on whilst doing missions.
    If you could upload a copy of your log please via the upload a file tab then we can have a better idea as to what is going on
     
  19. Xentro

    Xentro Member Honorable Member Wiki Editor

    Its still in there (Its activated by default) but the setting option werent setup correctly and thats the reason why it wont show.
    There is an simple solution if you want to deactivate it and that is to open the GameExtenstion.xml file in your savegame directory
    Change this line to
    Code:
    <module active="true" name="FIX_FRUIT_GROWTH_DURING_MISSION"/>
    To
    Code:
    <module active="false" name="FIX_FRUIT_GROWTH_DURING_MISSION"/>
    Beware though that changing all other values wont currently be shown in the setting screen as it dont support it at this moment.
    The proper solution is included in the next update.
     
    Edd Johns likes this.
  20. Nestoche

    Nestoche New Member

    Thanks for the reply Enzosnext...here is the log file as requested....
     

    Attached Files:

    • log.txt
      File size:
      17.4 KB
      Views:
      6

Share This Page