1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird Error

Discussion in 'Ingaming' started by TommyLadd17, Nov 21, 2016.

  1. TommyLadd17

    TommyLadd17 Member

    im getting a weird error that i have never seen before,
    Validity check failed in TransformGroup_localToWorld:
    ..\..\..\src\engine\app\ReflectionAndScriptBinding.cpp (3077): MathUtil::isNaN(pArgs->arg[0].f) == 0
    LUA call stack:
    =dataS/scripts/vehicles/Vehicle.lua (0) : printCallstack
    =dataS/scripts/network/Server.lua (0) : update
    =dataS/scripts/BaseMission.lua (0) : update
    =dataS/scripts/FSBaseMission.lua (0) : update
    =dataS/scripts/missions/mission00.lua (0) : update
    =dataS/scripts/main.lua (0) : update
    Validity check failed in TransformGroup_localToWorld:
    ..\..\..\src\engine\app\ReflectionAndScriptBinding.cpp (3077): MathUtil::isFinite(pArgs->arg[0].f) != 0
    LUA call stack:
    =dataS/scripts/vehicles/Vehicle.lua (0) : printCallstack
    =dataS/scripts/network/Server.lua (0) : update
    =dataS/scripts/BaseMission.lua (0) : update
    =dataS/scripts/FSBaseMission.lua (0) : update
    =dataS/scripts/missions/mission00.lua (0) : update
    =dataS/scripts/main.lua (0) : update

    can someone tell me what this means or why its coming up? cheers
     
  2. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    Hi Tommy, can you please give a description of when this error pops up, adn what it does to your game?

    Is is bound to a specific mod, you added, or anything else. we only have the error from your log, but very often a full log provides a lot of extra information that can help define the problem.
     
  3. TommyLadd17

    TommyLadd17 Member

    i have been trying to get NI moddings ifor williams 18foot flatbed to work in fs17, i have taken all the extra parts out ( the folding sides, ramps and the likes) because i only want to use it for bales on the back of the pickup. i remade the modDesc and the lm18.xml basing them off of the ingame fliegel bale trailer.
    when loading it in game it buys alright, but the games runs really badly after wards, (im guessing this is from the call stacks, as it just keeps repeating the same lines in the log) the wheel are also no sitting right but that just needs a bit of tlc.

    https://photos.dropbox.com/app/timeline/lightbox

    that is whatit looks like in GE the ratchet straps and all are working. however once i tried to attach it the game went nuts, dropped to less than 1fps and the pickup started showing like a couple hundred mph in the speedo.

    i have added the full log file too, let me know if you need the trailer.xml too
     

    Attached Files:

    • log.txt
      File size:
      175.3 KB
      Views:
      3
  4. dj

    dj Testing Staff Testing Staff SOB Modding Wiki Contributor

    Can you please post the correct link to your dropbox, now I have to login to see the picture, I think that is the wrong shared link

    always check the settings of the collisions, lots of people forget ot change the collision mask.
    always compare to a default trailer if the compund child and stuff like that is good.

    do you have a collision for the locking script of giants (for the straps)?

    I think your main problem is in these lines:
    Code:
    C:/Users/Tommy/Documents/My Games/FarmingSimulator2017/mods/ifor_cattletrailer/flatbed_body.i3d (10.73) ms
    Physics: wheel shape not found, object LM186 wheelShapeIndex 139
    Physics: setWheelShapeForcePoint failed, wheel shape with index 139 does not exist.
    
    Physics: enqueueControlWheelShape failed, wheel shape with index 139 does not exist.
    Physics: wheel shape not found, object LM186 wheelShapeIndex 140
    
    I think you have to try to use/add default giants wheels with working wheelshaders, and resize them to get this trailer to work.
     

Share This Page